spring cloud alibaba 2022.0.0.0 最低jdk版本 nacos-opensource | Nacos
Nacos 配置中心安全问题汇总及解决方案 点此了解

spring cloud alibaba 2022.0.0.0 最低jdk版本 nacos-opensource


用户问题 :

spring cloud alibaba 2022.0.0.0 最低jdk版本 nacos-opensource


专家官方解答 :

根据已有的知识信息,我们可以分析如下:

  1. Spring Cloud Alibaba与Nacos的版本对应关系:要确定Spring Cloud Alibaba 2022.0.0.0版本所支持的最低JDK版本,最直接的方式是参考SCA团队提供的官方说明。根据提及的sca网站的版本说明,这里应有最详尽和最新的版本兼容性信息。因此,建议直接访问该链接获取关于Spring Cloud Alibaba 2022.0.0.0版本的详细兼容性报告,包括其支持的最低JDK版本。

  2. Nacos的JDK支持范围:另一方面,我们知道Nacos本身支持从JDK8到JDK17的所有版本,并理论上支持更高版本,但需要额外的测试验证。这表明,只要Spring Cloud Alibaba 2022.0.0.0没有特别限制,它至少应该能够与这些Nacos支持的JDK版本兼容。

综上所述,为了获得Spring Cloud Alibaba 2022.0.0.0确切的最低JDK版本要求,请直接查阅官方文档。不过,基于Nacos的支持情况,可以推测该版本的Spring Cloud Alibaba至少应与JDK8兼容。为了确保应用的稳定运行,推荐按照官方推荐的JDK版本进行部署。

---------------

参考链接 :

*专家经验:springcloud alibaba 和nacos版本对应

*FAQ

*专家经验:Does nacos 2.2.3 support jdk17

---------------

答疑服务说明:

本内容经由技术专家审阅的用户问答的镜像生成,我们提供了专家智能答疑服务,在页面的右下的浮窗”专家答疑“。您也可以访问 : 全局专家答疑 。 咨询其他产品的的问题

反馈

如问答有错漏,欢迎点:差评给我们反馈。